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Super Utilities for Microsoft Visio 
For Microsoft Visio 2010 / 2013 / 2016 / 2019 / 2024 

 

Visio Super Utilities adds a new ribbon to Microsoft Visio 

 

 

Each section of the ribbon (Document, Page, Shape, Stencil etc.) gives you a selection of tools that 

I’ve developed over the years. I hope you also find them useful. 
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Document utilities 

Close all documents without saving 

This will close all the currently open documents. If there are unsaved changes then they will be 

lost. Equivalent to a “No to All” response when asked to save documents when Visio closes. When 

you are creating documents by automation and have 83 unwanted but unsaved documents then 

you may realise how useful this is! 

Mark all documents saved 

When creating a large number of documents, if the documents are not saved or marked as saved 

then when you want to exit from Visio without saving the documents, Visio will ask whether you 

want to save each unsaved document. If you have 100 unsaved documents open then this is 

inconvenient to say the least. 

By marking all documents saved, you may exit from Visio without being asked to save the 

documents. 

Export Documents/Pages as images 

If you need to import Visio documents into a word processor, send them by email or prepare 

images for a web page then the standard Visio menu options only allow you to save one page at a 

time. 

SuperUtils enables you to export all the pages of the current document or of all the open 

documents to be saved as images. 

The 'Export File Path' is where the images get saved, use the yellow 'change folder' dialog box to 

change this path (you can also create new folders here). 

The 'Export image name' options allow you to choose the name created for the image. It can be 

either the document name followed by the page name (with options of space or underline as 

separator), or just the page name by itself. When exporting images from multiple documents be 

careful with this option as any duplicate page names will overwrite a page image of the same 

name. 

The 'Export as image type' can be set to one of (BMP, DWG, DXF, EMF, EMZ, GIF, JPG, PNG, SVG, 

SVGZ, TIF, WMF). 
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Alternative webpage export 

The built-in web page export available in Visio is very powerful and has some very nice features. 

However, the output it produces can be very complicated and if it is to be incorporated into other 

web pages with manual editing then an alternative, simpler output may be useful. 

Also, we've added a few features we find useful. Please be aware though that it is very easy to 

create Visio pages with names that are not very friendly for webpages i.e. pages can contain '?', '<', 

'>' and so forth as well as names containing Unicode characters. This utility does not cope at all 

well with names like this. 

Save File Path The folder for all output files. use the yellow 'change folder' dialog box to change 

this path (you can also create new folders here). 

Include HTML Head File Include the contents of this file before the HTML </head> tag. 

Include Header File Include the contents of this file before the images. 

Include Footer File Include the contents of this file after all the images. 

File Type Choose one of htm, html or php. 

Image Type Choose one of GIF, JPG, PNG or SVG. SVG requires that you have an SVG plug-in 

installed in your browser. 

Page Output One web page per Visio page or the whole lot in one file. 



Super Utilities for Microsoft Visio Version 3.11  October 2024 

Page 4 of 36 

HTML/XHTML Choose the type of output required. 

Use Tables Whether to use a table to locate the image files. 

Separator between images Adds a horizontal separator line between each image. 

  

 

Shape Text Export (current document) 

This feature reads all the text in each shape on all pages within the current document and outputs 

it to the dialog box. 

From here all the text can be read and saved if required. 

Shapes in Document Report 

A document-wide version of the Shapes on Page Report but repeats for each page in the document 

and provides a total shape count for all pages at the end. 

 

Count Shapes in Document 

Displays a list of the counts of all the different shapes on all the pages within a document. 

A page version of this is available at Count Shapes on Page. 

 

https://vsu-wiki.paulherber.co.uk/doku.php?id=shapes_on_page_report
https://vsu-wiki.paulherber.co.uk/doku.php?id=count_shapes_on_page
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Word Count Report 

This feature counts all the words in each shape and page of the current document, displaying a 

total for each page and a total for the whole document, however complex the shape, remembering 

that shapes can be groups of other shapes to any depth. 

 

Copy Document to Other Document (Document Merge) 

This copies all the pages of the current document into another open document. To use this feature 

open both documents, go to the document you wish to copy from, select “Copy Document to 

Other Document” from the SuperUtils → Document menu, from the dialog box select the 

document where you want to copy to and select OK. All the pages will be copied to that document. 

Copy and merge limitations 

Copying and merging some pages and documents may not work correctly when the positioning of 

shapes on a page is under the control of Visio or an add-on within Visio. Various of the built-in 

diagram types within Visio are of this type: 

• Organization Chart 

• Cross-functional Flowchart 

• Maps and Floor Plans 

• Calendar 

• Gantt Chart 

• Pert Chart 

• Timeline 

Shape position, shape name, connections and other factors can all be under the control of Visio, so 

copying a diagram may result in anything from small imperfections to a total mess. There is 

nothing that can be done about this. 

Compare Documents 

A document-wide version of Compare Pages. If both documents have the same number of pages 

then a page-by-page compare is performed, otherwise the page names are compared to try to 

identify where the first difference may be found. 

Once you have an idea about which pages might be different, use the Page → Compare Pages 

utility to find how the pages differ. 

 

 

List all open Documents 

When dealing with a large number of documents, the built-in Visio method of selecting which 

document to view is far from ideal. Use the “List all open Documents” menu to select which 

document to view. It provides the document type and name to allow you to clearly see all the 

https://vsu-wiki.paulherber.co.uk/doku.php?id=copy_and_merge_limitations
https://vsu-wiki.paulherber.co.uk/doku.php?id=compare_pages
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current documents that are open. The current document is highlighted. Note that if there are a 

very large number of documents then it can take a few seconds to populate the list. 

To save the list of documents in a text file, use the 'Save' button. 

  

 

Hyperlink Report/Check 

This feature reads all the shapes on the current page or document and outputs a list of all the 

hyperlinks within these shapes. It also takes into account grouped shapes where different parts of 

a shape may contain hyperlinks. 

Hyperlink Check tests the existence of all the linked documents, whether internal or on the 

internet. 

 

Layers Report/Check 

This feature reports all the layers used on the current page or document and outputs a list of all 

the layer names. It also checks that the layer Name and NameU are both set and whether there is 

any difference between the two. 
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Document Comments Report 

This generates a report on all comments that exist in the current document. Copy the report by 

selecting the text and use the right-click Copy menu. The report can also be saved to a file from the 

Save Text button. 

 

Convert Comments to Text Boxes 

Comments that have been added to a Visio page or document cannot be selected, searched, 

spellchecked or similar. Now you can convert comments into text boxes and use them in the same 

way as any other shape. 

The action of converting the comments into text boxes can be undone using the Edit → Undo 

menu. 

 

Copy and Paste 

Copy, Paste and Delete Shapedata 

You can use this utility to copy Shapedata from one shape (or master), or sub-shape to another or 

a page. Just select the shape from which you want to copy and use the SuperUtils → Shape → 

Copy → Shapedata menu, then select the shape or shapes to which you wish to copy these 

properties and use the SuperUtils → Shape → Paste → Shapedata menu. Or you can paste the 

Shapedata to a page with the SuperUtils → Page → Paste → Shapedata menu. Once a set of 

Shapedata has been copied they can be used to paste many times to as many shapes or pages as 

you want. 

You can even paste multiple times to the same shape but Visio will allocate a new name to any 

duplicate row as a shape cannot have two rows with the same name. 

The properties are not stored in the regular copy/paste buffer so you can use normal copy and 

paste operations without overwriting any stored Shapedata. 

You can also delete the Shapedata from one or more shapes (or masters) using the SuperUtils → 

Shape → Delete → Shapedata menu. 

 

Copy, Paste and Delete User-defined Cells 

You can copy user-defined cells from one shape (or master) to another or to a page. 

Once a set of user-defined cells has been copied they can be used to paste many times to as many 

shapes or pages as you want. 

The cells are not stored in the regular copy/paste buffer so you can use the standard copy and 

paste operations without overwriting any stored user-defined cells. 

This utility can also be used to delete all the user-defined cells for any number of shapes on a page. 
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Export All Images 

You can export all embedded media files that are contained in the Visio file to a folder. For 

example, all photos from the Org Chat diagram.  

The file must be saved for this to work. 

When using this command, you are prompted to select the target folder. After you confirm your 

selection, the embedded images are exported to that folder, and it is opened in Windows Explorer. 
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Page utilities 

Export Pages as images 

See section for Documents 

 

Alternative webpage export 

See section for Documents 

 

Shapes on Page 

Sometimes when developing Visio applications you are left wondering why a certain shape on a 

page isn't being recognised. This utility will list all the shapes on the current page. 

You can select the items to be listed from the Options dialog, this will enable you to display, for 

example, just a list of all the shape names on the page. 

The output from this utility can be saved to a text file using the “Save Text” button. 

A document-wide version of this can be found at Shapes in Document Report. 

https://vsu-wiki.paulherber.co.uk/doku.php?id=shapes_in_document_report
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Count Shapes on Page 

Displays a list of the counts of all the different shapes on a page. 

A document-wide version of this is available at Count Shapes in Document. 

 

 

Word Count Report 

See section for Documents 

 

Shape Text Export (current page) 

This feature reads all the text in each shape on the current page and outputs it to the dialog box. 

From here all the text can be read and saved if required. 

Page Report 

Reports upon different values for the Name, NameU and ID properties of all the pages in the 

current document. 

Checks page names for leading and trailing spaces and asks if you wish to correct this potential 

problem. If the page has its invisible attribute set then you will be asked if you want to make the 

page visible. 

 

Pagesheet Shapedata Report 

A problem that we had in the past was that a Pagesheet Shapedata property had not been set 

correctly but this couldn't be seen in the standard Shapesheet. It turned out that the property 

Name and LocalName were different. This utility may help you find similar problems. 

https://vsu-wiki.paulherber.co.uk/doku.php?id=count_shapes_in_document
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Compare Pages 

Select the document and/or page to compare with the current page and list the differences. Each 

page must have the same number of shapes. 

For a document-wide version see Compare Documents. 

 

Compare Page Properties 

Sometimes you might just want to compare the properties of two pages as this could show up a 

reason why routing or shape placement is different. 

 

Copy Current Page 

Duplicate Page / Copy Page to other Document / Copy Current Page as New 
Document 

This will copy everything* in and on the current page and copy it to: 

• a new page in the current document (i.e. duplicate page) 

• copy the page into another document (this must be another document opened in Visio) 

https://vsu-wiki.paulherber.co.uk/doku.php?id=compare_documents
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• or copy it into a brand new document 

Visio decides on the name of the new page; you may want to rename it. There are potential 

problems with copying a whole page: 

• Other add-ons may have an effect on pages being created and shapes being dropped on a 

page which may interfere with the operation of this add-on. 

However, in most cases this feature will make a complete copy of a page. Please let us know of any 

special problems that you find with this. 

Duplicate page asks how many duplicates should be made using a dialog similar to “Add new 

pages” below. Once you've copied a page to another or a new document you can then duplicate it 

by Duplicate Page. 

Please Note: Page Annotations are not copied on purpose as these are normally used to indicate 

that a page has been commented or reviewed by other people. 

 

Copy all Pages to Separate Documents 

With this menu you can split a document of n pages into n separate documents. You will be asked 

if you want to copy over each page's name, if not then each page will be given the default new 

page name allocated by Visio (this is language dependant, the English language version being 

“Page-1”). 

 

Add multiple new pages 

Normally, adding new pages to a Visio document can only be done 1 page at a time, if you want to 

add 25 new pages then it'll take you a long time. 

This utility will allow you add as many pages as you want in one simple operation. No range 

checking is done on the number of pages you want to add except only 3 digits are allowed. 

The addition of multiple new pages can be undone from the Edit → Undo menu. 
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List/Goto Page 

When dealing with a document containing a large number of pages, the built-in Visio method of 

selecting which page to view is far from ideal. 

Use the 'List/Goto Page' menu to select which page to view. The current page is highlighted. 

The list of pages is fully Unicode compatible. Note that if there are a very large number of pages 

then it can take a few seconds to populate the list. 

To save the list of pages in a text file, use the 'Save' button. 
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Rename Pages 

Renaming a large number of pages can be a long job. If all the pages need to be renamed 

sequentially then use this utility. 

The example dialog will rename all the pages in the current document as “page-42”, “page-43”, 

“page-44” etc. The start text is always used as the first part of the new name and the end text is 

always placed at the end (seem logical?) - either or both may be left blank. The Page number auto-

increments for each page from the starting point that you define, empty is taken to be 0. However, 

if the page number is negative then the page number will auto-decrement i.e. your pages will be 

renamed “page-42”, “page-41”, “page-40” etc. 

The page renaming can be undone in one unit using the Edit → Undo menu. 

  

 

Hyperlink Report/Check 

This feature reads all the shapes on the current page or document and outputs a list of all the 

hyperlinks within these shapes. It also takes into account grouped shapes where different parts of 

a shape may contain hyperlinks. 

Hyperlink Check tests the existence of all the linked documents, whether internal or on the 

internet. 
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Layers Report/Check 

This feature reports all the layers used on the current page or document and outputs a list of all 

the layer names. It also checks that the layer Name and NameU are both set and whether there is 

any difference between the two. 

 

Page Comments Report 

This displays a report of all comments made on a page, these comments can be copied and pasted 

into another document by selecting the text and right-click menu. The report can also be saved to 

a file from the Save Text button. 

 

Convert Comments to Text Boxes 

Comments that have been added to a Visio page or document cannot be selected, searched, 

spellchecked or similar. Now you can convert comments into text boxes and use them in the same 

way as any other shape. 

The action of converting the comments into text boxes can be undone using the Edit → Undo 

menu. 

 

Copy, Paste and Delete 

Copy, Paste and Delete Shapedata 

You can use this utility to copy Shapedata from one shape (or master), or sub-shape to another or 

a page. Just select the shape from which you want to copy and use the SuperUtils → Shape → 

Copy → Shapedata menu, then select the shape or shapes to which you wish to copy these 

properties and use the SuperUtils → Shape → Paste → Shapedata menu. Or you can paste the 

Shapedata to a page with the SuperUtils → Page → Paste → Shapedata menu. Once a set of 

Shapedata has been copied they can be used to paste many times to as many shapes or pages as 

you want. 

You can even paste multiple times to the same shape but Visio will allocate a new name to any 

duplicate row as a shape cannot have two rows with the same name. 

The properties are not stored in the regular copy/paste buffer so you can use normal copy and 

paste operations without overwriting any stored Shapedata. 

You can also delete the Shapedata from one or more shapes (or masters) using the SuperUtils → 

Shape → Delete → Shapedata menu. 

 

Copy, Paste and Delete User-defined Cells 

You can copy user-defined cells from one shape (or master) to another or to a page. 
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Once a set of user-defined cells has been copied they can be used to paste many times to as many 

shapes or pages as you want. 

The cells are not stored in the regular copy/paste buffer so you can use the standard copy and 

paste operations without overwriting any stored user-defined cells. 

This utility can also be used to delete all the user-defined cells for any number of shapes on a page. 

 

Copy, Paste and Delete Action Cells 

You can copy action cells from one shape (or master) to another or to a page. 

Once a set of action cells has been copied they can be used to paste many times to as many shapes 

or pages as you want. 

The cells are not stored in the regular copy/paste buffer so you can use the standard copy and 

paste operations without overwriting any stored action cells. 

This utility can also be used to delete all the action cells for any number of shapes on a page. 

 

Copy and Paste Layers 

Use this menu to copy and paste layers between pages. The copied layers are stored internally and 

can be pasted any number of times to multiple pages. 

Just go to the appropriate page and use the Page → Copy → Layers, then go to the page where you 

want to copy to and then use the Page → Paste → Layers. 

 

Select by Master 

Use this menu to allow selecting shapes on the page based on their master, similar to “Select by 

Layer” Visio built-in function, but by shapes’ master. The menu shows a form with a list of master 

names. Checking corresponding master name selects all shapes that have that master. 
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Shape utilities 

 

Selected Shape(s) Text Export 

This feature reads all the text in each selected shape on the current page and outputs it to the 

dialog box. 

From here all the text can be read and saved if required. 

 

Grouped Shape Report 

This report shows the contents of a grouped shape. It lists all the shapes that make up the group 

together with all of the identifiers for those shapes. 

If the Name and NameU for a shape within a group are different then you will be asked whether 

you want to rename the shape. 

  

 

Compare Shapes 

Compare two shapes and list the differences. At the moment this feature cannot work with 

grouped shapes. Just select the two shapes to be compared. 
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The X and Y coordinates of the shape's position on the page are not compared as the chances are 

that they will always be different. 

  

 

Shape(s) Substitute 

It can be very useful to be able to substitute one or more shapes in a Visio diagram with a different 

shape. 

These utilities can help you with that. 

Select the shape (or type of shape) that you wish to replace. Select Shape → Shape Substitute 

from the ribbon. 
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The Shape(s) to Replace box will show options of which shapes to replace and the Replacement 

Scope boxes will allow you to change where the shape substitution will take place. 

Choose the shape that you wish to be the replacement shape from the New Shape box. This will 

list all the shapes in all the open stencils. 

 

Remove small shape details 

You may have a very detailed drawing that needs to have all the small details removed. Another 

area where this is useful is when you've imported an AutoCAD diagram. These often contain many 

very small shapes that are not useful. 

With this utility select the shapes you wish to work on, select this tool from the ribbon menu, you 

will be asked the size of the items to be removed (in units of mm, cm, m, inches, feet or yards). The 

shape must be smaller than BOTH the selected height and width. 

This tool even gets down into grouped shapes to remove small items. 

If you are unhappy with the shapes that have been removed then the operation may be undone 

via the normal Visio Undo menu. 

Copy, Paste and Delete 

Copy, Paste and Delete Shapedata 

You can use this utility to copy Shapedata from one shape (or master), or sub-shape to another or 

a page. Just select the shape from which you want to copy and use the SuperUtils → Shape → 

Copy → Shapedata menu, then select the shape or shapes to which you wish to copy these 
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properties and use the SuperUtils → Shape → Paste → Shapedata menu. Or you can paste the 

Shapedata to a page with the SuperUtils → Page → Paste → Shapedata menu. Once a set of 

Shapedata has been copied they can be used to paste many times to as many shapes or pages as 

you want. 

You can even paste multiple times to the same shape but Visio will allocate a new name to any 

duplicate row as a shape cannot have two rows with the same name. 

The properties are not stored in the regular copy/paste buffer so you can use normal copy and 

paste operations without overwriting any stored Shapedata. 

You can also delete the Shapedata from one or more shapes (or masters) using the SuperUtils → 

Shape → Delete → Shapedata menu. 

 

Copy, Paste and Delete Connection Points 

You can copy connection points from one shape (or master) to another, pasting back to the original 

shape duplicates all the connection points which can be useful if you want, say, to create a large 

number of connection points and then edit them. 

Once a set of connection points has been copied they can be used to paste many times to as many 

shapes as you want. 

The connection points are not stored in the regular copy/paste buffer so you can use normal copy 

and paste operations without overwriting any stored connection points. 

This utility can also be used to delete all the connection points for any number of shapes on a 

page, even grouped shapes. 

 

Copy, Paste and Delete User-defined Cells 

You can copy user-defined cells from one shape (or master) to another or to a page. 

Once a set of user-defined cells has been copied they can be used to paste many times to as many 

shapes or pages as you want. 

The cells are not stored in the regular copy/paste buffer so you can use the standard copy and 

paste operations without overwriting any stored user-defined cells. 

This utility can also be used to delete all the user-defined cells for any number of shapes on a page. 

 

 

 

Copy, Paste and Delete Action Cells 

You can copy action cells from one shape (or master) to another or to a page. 
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Once a set of action cells has been copied they can be used to paste many times to as many shapes 

or pages as you want. 

The cells are not stored in the regular copy/paste buffer so you can use the standard copy and 

paste operations without overwriting any stored action cells. 

This utility can also be used to delete all the action cells for any number of shapes on a page. 

 

 

Copy and Paste Text Transform and Character Formatting 

If you've ever tried to copy text formats by using the Format Painter you may have been 

disappointed because it doesn't copy any of the Text Transform section, even the bits it does copy 

only copies values, so if you have a formula set up to control font size all you can copy is the 

current value. 

You can now get around this by using this Copy and Paste of the Text Transform and Character 

Formatting. 

Copying the Text Transform and Character Formatting stores the copied information into an 

internal memory are so it doesn't affect the normal copy and paste operation. 

Select the shape you wish to copy from and use the Copy feature, then select the shape or shapes 

you wish to copy to and use the Paste feature. 

The Paste can be used as many times as you like, it only gets cleared when you close Visio. 

 

Shape Nudge 

You might want to move a shape or selection of shapes by a small or a defined distance, this utility 

will move the selected shape or shapes by the user-defined distance and units. No range checking 

is done so if you move a shape 100000 yards or meters and it goes way off screen then just move it 

back in the opposite direction (or use the Edit → Undo menu). 

The dialog box can be moved anywhere on your screen to keep it out of the way of the shapes that 

you are moving, also you can use other features of Visio without having to close the Nudge 

window. 

Units can be selected in (metric) mm, cm, m and (imperial) in, ft and yd. 

To help maintain connectors between shapes select the “Ignore connectors” box. Nudge will ignore 

these shapes but they will then move together with the shapes they are connected to. 

A shape nudge action can be undone as one unit by using the Undo menu (or Control-Z) and the 

direction of the nudges are identified within the undo options. 



Super Utilities for Microsoft Visio Version 3.11  October 2024 

Page 23 of 36 

  

 

Clear Shape Text Formatting 

Use this menu to clear all the text formatting for the selected shapes. The text font is set to font 0 

(Arial) at 8pt and the colour is set to black. If the text has been set as protected then the 

formatting will still be cleared and any protection is retained. 

 

Instant Isometrics 

Converts selected shape geometry to isometric view. Please note that complex shapes or shapes 

with protected parts are not supported. The isomeric view transformation code is credited by Juni 

Yoda.  
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Stencil utilities 

 

Startup Stencils 

Sometimes you always want to load a number of stencils, the shapes that you use every day. From 

the Manage Startup Stencils menu just add the stencils that you want to use. You can delete the 

ones you no longer require by selecting them and clicking the Delete button. A stencil can also be 

temporarily prevented from being opened by turning off its check mark. You can also prevent any 

of the stencils being opened by setting the Active tick box to unticked. 

 

Close All Stencils (without saving) 

This option closes all the open stencils for all open documents. 

 

Stencil Report 

When developing a stencil or Visio application, the Name and NameU of a master shape within a 

stencil can be very important, especially when the Name and NameU are expected to be identical. 

Normally the NameU of a master shape can only be set when the master shape is created and this 

same NameU will be kept when a new shape is developed from an original or the shape is 

renamed. 

For each shape within the currently open stencils this utility firstly lists the Name and NameU and 

then checks that the Name and NameU are identical, if not then the user is asked whether the 

NameU should be set to be identical to Name. Then the shape's prompt, hidden status, search 

keywords, copyright text and icon size all are output followed a check on whether the shape's icon 

is always updated whenever the master shape is edited. Finally, some shapes will be listed here but 

still not be visible within the stencil. These shapes can be custom line patterns, line ends and fill 

patterns. 

The output from this utility can be saved to a text file using the “Save Text” button. 

At the end of the report a summary is given of the total number of shapes with the number of 

stencils. 

The output of this report can be customized to generate only the information you want, e.g. if you 

only to list all the shapes within the stencil the at the initial dialog have only the Name box ticked. 

This will give you a listing like: 

BASIC_M.vssx 
 Rectangle 
 Ellipse 
 Square 
 Triangle 
 Circle 
 Pentagon 
 Right Triangle 
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 Heptagon 
 Hexagon 
 Decagon 
 Octagon 
 Parallelogram 
 Can 
 Diamond 
 Trapezoid 
 Chevron 
 Cross 
 4-Point Star 
 Cube 
 6-Point Star 
 5-Point Star 
 16-Point Star 
 7-Point Star 
 32-Point Star 
 24-Point Star 
 Single Snip Corner Rectangle 
 Rounded Rectangle 
 Snip Diagonal Corner Rectangle 
 Snip Same Side Corner Rectangle 
 Round Same Side Corner Rectangle 
 Single Round Corner Rectangle 
 Snip and Round Single Corner Rectangle 
 Round Diagonal Corner Rectangle 
 Round Corner Rectangle 
 Snip Corner Rectangle 
 Frame 
 Snip and Round Corner Rectangle 
 L Shape 
 Frame Corner 
 Plaque 
 Diagonal Stripe 
 No Symbol 
 Donut 
 Left Parenthesis 
 Center Drag Circle 
 Left Brace 
 Right Parenthesis 
 Right Brace 
Stencil report finished. 

You can now easily build a complete list of all the shapes within Visio! 

 

Stencil Display 

Back in the days of Visio 2000 there was a useful feature for showing a graphical display of all the 

shapes in a stencil. For some reason this has been discontinued. Never mind, I've written an 

alternative version. This can display the shapes in one stencil or for all the open stencils. Use Visio 

to open the stencil and choose Stencil Display from the menu SuperUtils → Stencil → Stencil 

Display, select the stencil you want to show (or scroll to the end of the list to select “All open 

stencils”), on a standard portrait format page 3 by 5 images should be OK, if you want more or 

fewer images per page then adjust these numbers. For your further convenience the page name is 
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set to be the same as the stencil name, and if more than one page is required for each stencil then 

2, 3, 4 etc gets added to any extra pages. Please note that some Visio shapes cannot be displayed 

properly: 

• Backgrounds 

• Shapes that invoke an add-on 

• Shapes that calculate their size from another shape 

• Shapes that extend their geometry outside of their nominal dimensions. 
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Update Stencil Master BaseIDs 

Warning - this is a very dangerous feature - only use it if you know what you are doing! 

If you create new master shapes you may need to change the shape's BaseID value, every master 

should have a different value, but this can only be changed programmatically. It appears to be very 

poorly documented. 

Ensure only one Visio document is open, open the stencil you wish to update, then use the utility 

to change the BaseID values. When you create a new shape put that shape into it's own stencil 

initially and update the master's BaseID in that stencil, then move the new shape into its 

destination stencil. You only need to do this once per master. 

 

Delete Item from Stencil 

Some shapes in a stencil can be invisible or cannot be deleted by the normal method of opening 

the stencil for edit, selecting the shape and selecting delete from the menu. If you have a shape 

like this that you need to delete from a stencil then: 

• Make a copy of the stencil first in case it all goes wrong! 

• Now open a blank document then open the stencil. 

• Use the menu SuperUtils → Stencil → Stencil Report and get the index number of the shape 

that you need to delete. 

• Now use the Delete Item from Stencil menu to delete this item. 

 

Create Stencil Illustration 

As a vendor of a large number of Visio stencils I have a frequent need to create screen shots of one 

or more stencils for use on web pages, help files and instruction manuals. Until now I'd have to fire 

up the appropriate version of Visio, ensure the stencils were easily available to Visio, start my 

graphics software, load a stencil, adjust its size, do a screen dump, load it into the graphics editor, 

crop the image to just the stencil area, then save it. Now repeat for 50 stencils!. And how do you 

cope with a stencil containing 100 shapes so some are off the bottom of the screen? What a 

kerfuffle! 

This little utility will fix that, just load up the stencils you want to create illustrations for, start this 

utility from the menu, choose which stencil (or all open stencils), select which version of Visio and 

the style of illustration and press OK. The page name will get changed to reflect the stencil name 

so when you want to save all the pages as images the images will have suitable names (see menu 

Super Utilities → Page → Export Pages as Images). 

You can have your illustrations done in just minutes! 
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When creating stencils in one of the 3 formats that Visio uses it can be very important to convert 

between these 3 formats quickly and easily, OK, there is a Save As command on the stencil toolbar, 

but what if you have 100 stencils to convert? 

Put your stencils into a new folder and use this command to select the stencil input format, then 

select the folder to convert, then select the output format. The input and output formats can be in 

VSS/ VSX or VSSX/VSSM formats. 

Note that the VSSX/VSSM format was not introduced until Visio 2013 so this option is not available 

for Visio 2010. 

Saving in VSX format is no longer available as of Visio 2013 so this option is disabled in version 

2013 onwards. 
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Also note that the output format cannot be the same as the input format. 

Warning. If files of the same name and type as the output format already exist then they will be 

overwritten with no warning. 
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Hidden Visio Commands 

 

Array Shapes 

Creates a table layout of shapes, but hidden away on a totally inappropriate menu. Why would 

anyone use the View menu to find something like this? Only available in Visio Pro. 

 

Auto-Correct Options 

OK, these are not quite so useful as some of the others but if you do need them I'll bet you'd not 

be able to find them. 

 

Snap and Glue Settings 

These are very useful settings, for some reason hidden away so they can't be found. 

 

Center Drawing 

Centers the shapes on the page. Useful. Why hide it? 

 

Shape Operations 

There are a number of shape operations that are only available on the Developer ribbon, don't 

know why that was decided, they are useful things to have available. 

So, here are the shape Union, Combine, Fragment, Intersect, Subtract, Join, Trim and Offset 

commands. 

Here is also the Update Alignment Box command that has also been hidden. 

 

Connect Shapes 

Draw a number of shapes on a page, select them all, now use this Connect Shapes command. How 

useful is that???? Why hide it? 

 

Visio About 

Most software is only too happy to provide an About box so you see the software version etc. 

From Visio 2010 onwards Microsoft have decided not only to make it difficult to find the Visio 

About box but to actually not provide a menu entry for it at all. You have to edit the ribbon or 

Quick-access system to be able to get to it! 

So, here it is, easy to get at now. Simples. 

https://vsu-wiki.paulherber.co.uk/doku.php?id=array_shapes
https://vsu-wiki.paulherber.co.uk/doku.php?id=auto-correct_options
https://vsu-wiki.paulherber.co.uk/doku.php?id=snap_and_glue_settings
https://vsu-wiki.paulherber.co.uk/doku.php?id=center_drawing
https://vsu-wiki.paulherber.co.uk/doku.php?id=shape_operations
https://vsu-wiki.paulherber.co.uk/doku.php?id=connect_shapes
https://vsu-wiki.paulherber.co.uk/doku.php?id=visio_about
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Most-Recently Used Stencils 

 

Visio keeps a list of your most recently used documents and templates but not stencils. 

Super Utilities can track up to 50 of your most recent stencils (limited to just 3 in the unregistered 

version). 

Whenever a stencil is opened the name of the stencil is kept in a list and can be found at the menu 

Most-recent stencils, just select the stencil you want and click Load. 
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Org-Chart Tools 

 

The Org-Chart template within Visio gives you a ribbon with various options 

One thing missing though is the ability to do a headcount on the diagram, and in a large diagram 

that could take a long time manually. 

This utility allows you to create a headcount for the whole document, the current page, the 

current selection, or just the subordinates of the current selected shape (the headcount here does 

include the selected shape). 

Not only do you get the total headcount but also each individual position type e.g. Managers, 

Executives, Contractors etc. 

 

Org Chart Sort 

This feature allows you to re-order (sort) org chart employee cards (boxes) by a selected property 

(or multiple properties). It can sort vertical, horizontal, and side-by-side diagrams. 

 

- Supports sorting by property of choice. The property is supposed to be a Shape Data property. 

- Can sort by multiple properties (example: first sort by "department," then by "name"). In the 

form above, it first will sort by the “Sort By” field and then by “Then By” field. 

- It can sort immediate children but also can also sort recursively (the “Recurse” checkbox in the 

form above). 

- To sort in descending order (from Z to A, or from 9 to 1) us the “Sort in descending order” option. 

- Checking the “Run layout after sort” option will automatically run Org Chart layout command 

after the sort is completed. This may help if you get overlapping items after sort. 
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Options 

 

The Copy, Paste and Delete features can display a pop-up box to tell you when the requested 

action has been performed. Without this pop-up you may not know that anything has happened, 

but if you use these features a lot then the pop-up may get tiresome. 

The Most-Recently Used stencils option may be turned on or off and the maximum number of 

stencils set from 3 to 50 (it is set to 3 in the unregistered version). 
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Application utilities 

List all Add-ons 

When developing Visio add-ons it can be useful to know not only that your own add-on has been 

recognised but also the names of all the other add-ons recognised by Visio. If there is a clash of 

add-on names then one of the add-ons won't be working! The output from this utility can be saved 

to a text file using the “Save Text” button. 

  

 

 

Clear undo data 

Does what it says on the tin! Clears all the undo data within Visio. 

 


